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Promises of MBSE
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" Model Analysis
= Full Traceability

" Improved Content
= Validation
= Verification

= Trade Studies
= Custom Reporting
= Automations

CATIA Magic provides all of this, but it is capable of so much more!



Vo, What Can We Make CATIA Magic Do?
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= Anything we can imagine!*
= *and develop

= CATIA Magic utilizes a Java Application
Programming Interface (API) for its main
application and plugins
= Not the same as TWC’s REST API

= This APl is full of software designed to help build
the functionality that makes CATIA Magic so
powerful

= Some of the API is Closed (subject to change) while
the rest is Open (relatively stable between releases)

= CATIA Magic provides several methods for
accessing and utilizing its Open API




Where Can the API Be Used?
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V) Simulation
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= Accessible in Many Forms:

= Activity Diagrams -l

= Opaque Actions

e T e
= State Machine Diagrams ? )

= Behaviors (Entry/Do/Exit/Effect) : o -

" Guards |

= Change Events L — output = w naspeed)
= Parametric Diagrams

distance : Real output : Rea
par [Block] S
H steadyVelocity = 11.3mis } cock
= Constraint Block L
o n S ra I n OC S s getDiztance : DistanceFrom VaelocityFunction distance idistance Traveled = 5085 m
__J— [drstance = Distanc eFromi elocry Functon(velocty ime))
steadyVelocity TimeSpan =450 s

ar [Block] System| System |

= Can simplify simulation models by
shortcutting formal constructs with e L ———
code




N ) Structured Expressions
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. . Language:
= Accessible in Many Forms: ooy
= Custom Columns / Derived Properties o

= Dyn am |C Lege ] d S Script1(numerator, denominator)

= Validation Rules - i S
35 {
= Script is selectable as an operation in ., =
the Structured Expression window =
» Parameters can be added to the l s
operation at will and referenced .
directly in the script
= Scripts are often used to more easily | . gg;p
collect data for queries and to {7 2-® numerstor = Sizel
perform mathematical operations R | L & eut-Satcly Direct and Implied
. " enominator = Jize
(e.g. calculating percentages) | T & & Input= Findi
Script L Create parameter...



5 ) Automations and Feature Extensions
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" Plugins and macros provide §
additional functionality to the already
feature-heavy CATIA Magic Fi:-ro e Ierr':c:iflis\lndividual Fi|es\5e|ected£lementpopup.groo\;y
application Dbt

» Both utilize the APl and much of what
can be done could be written as a
plugin OR macro [C) Automatically run with default values

" Macros are generally used for
automating tasks and scalably
transforming model content

" Plugins are generally used to add new
features, often in the menu bar, like
wizards and or event-listeners



N )

Plugins vs Macros
Plugins Macros
= Pros: = Pros:

= Can Add Custom Menu Options
= |s Multi-threaded

= Can Listen For, Catch, and React to
Events

= Multiple Languages Supported
= Easy to Execute
= Can be Hot-keyed

= No Installation Needed
= Can be Bundled into an Installation

= Can Be Added to Projects and Managed
Package for a Team in TWC
= Cons: = Cons:

= Must Be Compiled in Java

= |s Single-threaded
= Must Be Installed on each User’s Cameo = Cannot Catch Events
Application



What is the Open API?
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Java API
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= An APl is a way for two computer
applications to communicate with 5.0 seanct: [ Souch ]

SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

each other via software code

" It’s a type of software interface that ~ ~ """
offers “services” to other pieces of
software - oy o i SO

= An application’s API consist of a set puoic clos stereoypeseper
of classes that are made available t0 | .. s st o tmios s st s
developers to use in their
applications

= APIs don’t include ALL classes for
application (Open vs Closed API), just —

Field Summary

£ Modifier and Type Field Description
the ones made available for use for e o of UML et
interfacing with the application ovmcdome: St
, . / : static UML2METAMODEL_PRIMITIVE TYPES Name of primitives package in the UML2 metamodel
= API’s hide the internal details of how a java. Lang. string
System or application Works’ but expose static UML2METAMODEL_URT URI of UML2 metamodel, must correspond UML standard profile

java.lang.String metamodel uri.

parts that may be useful for developers



N )
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UML Metamodel Classes

= Every class in UML is
represented by a Java class in
the API that conforms to the
UML specification by the OMG

These classes provide access to
get or set the fields in the
Specification Window

Notably, we do NOT use
Constructors to create these
elements

* The ElementsFactory is needed
for this

Once the UML element is
created, stereotypes are
placed on top using a helper
class

Element
= Parent of All
= element.get_relationshipOfRelatedElement() returns all relationships for an element
= element.getOwnedElement() returns all owned elements underneath this element (DOWN)
= element.getOwner() returns the owner of this element (UP)
= element.setOwner(someElement) places the element in the Containment Tree

Relationship
= Parent of All Relationships

NamedElement
= Provides the Name property (not all elements have a name)

Package / Model

= Containers within UML
Class / Property
= Common UML structural elements

Diagram
= Any diagram in Cameo (the type is determined by a property called DiagramType)

PresentationElement / DiagramPresentationElement
= Symbols on diagrams
» presentationElement.getElement() returns the element for the symbol




“ ) Application Classes (1)
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= The Application = Application
ClaSSGS_ConSiSt Of_ = The main class for current instance of CATIA Magic running
the main classes in = Getting the Instance of from Application is usually the first thing done in
the User Interface plugins/macros
= Nearly every = MainFrame
automation begins » The primary graphical user interface (GUI) of CATIA Magic
with accessing the » Provides access to the menus and for syncing windows created
Application
Instance, its " GUILog
GUIlLog, and its " The log file class for CATIA Magic
active Project. = Project
= |[f the model is to be = The instance of the project(s) active in the instance of CATIA Magic
edited, a session = Provides access to the root of the Containment Tree

must first be
created and then
closed when
completed. = SessionManager

= Manages sessions for actions taken in CATIA Magic (for undoing/redoing)

= ElementsFactory
= The element creation mechanism for a project




“ ) Application Classes (2)
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= Useful functions:
= Application.getlnstance().getProject()
= Get active project element
= Application.getInstance().getMainFrame()
= Get access to the GUI of CATIA Magic
= Application.getInstance().getGUILog().log(“Hello World”)
= Print to the log file
= project.getPrimaryModel()
= Returns the root Model element in the Containment Tree
= A great starting point for traversing the entire model
= project.getElementsFactory()
= Gets the elementsFactory to create new elements
= elementsFactory.createMETACLASSInstance()
= Creates a new element of type METACLASS
* mainFrame.getMainMenuBar()
= Gets the File -> Edit -> View etc. Menu Bar to add new buttons
= SessionManager.getinstance().createSession(“Session Name Here”)
= Creates a new session for making edits to the model
= SessionManager.getinstance().closeSession()
= Closes the active session



Vi Helper Classes (1)
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" The Helper Classes = StereotypesHelper

provide useful = Primary helper for working with stereotypes on elements and their tagged
features for values
working in the = CoreHelper
UML framework » Gets/sets the documentation of elements
" The most useful is = Gets/sets the source and target (client/supplier) of relationships
typically = Finder
StereotypesHelper = A utility class for finding elements within the Containment Tree meeting
= This applies given criteria
stereotypes, = ElementSelectionDIgFactory

searches for
elements, and
gets and sets
tagged values

= A factory for creating a Select Element Window in CATIA Magic

= Many options available for single/multi-select, default options selected,
and element creation allowed in window



Vo, Helper Classes (2)
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= Useful functions:
= StereotypesHelper.addStereotype(someElement,someStereotype)
= Adds a stereotype to an element
StereotypesHelper.hasStereotype(someElement,someStereotype)
= Checks if the element has a specific stereotype
= StereotypesHelper.getStereotypePropertyValue(someElement,someStereotype,”TagName”)
= Gets the Tagged Value of the element
= StereotypesHelper.setStereotypePropertyValue(someElement,someStereotype,” TagName”,value)
= Sets the Tagged Value of the element
= StereotypesHelper.getStereotypedElements(someStereotype)
= Returns ALL elements with that stereotype applied

= CoreHelper.getComment(someElement)
= Gets the documentation for an element

= CoreHelper.getClientElement(someRelationship)
= Gets the client/source of a relationship

= CoreHelper.getSupplierElement(someRelationship)
= Gets the supplier/target of a relationship

* Finder.byQualifiedName().find(project,”QUALIFIEDNAME")

= Finds the element with the given qualified name



Vo, Requiremen tion Sam
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project = Application.getInstance().getProject();
mainModelPackage - project.getPrimaryModel();
elementsFactory - project.getElementsFactory();

sysmlProfile Stereoty] getProfile(project, "SySML");
requirementStereotype elper . getStereotype(project, "Requirement"”,sysmlProfile);

)

newRequirement elementsFactory.createClassInstance();
newRequirement . setName(name) ;
Ste ypesHelper . addStereotype(newRequirement,requirementStereotype);
sHelper . setStereotypePropertyValue(newRequirement,requirementStereotype,"Id",id);
~.setStereotypePropertyValue(newRequirement,requirementStereotype, "Text",text);
newRequirement . setOwner(owner);

print( - )

1.getInstance() . getGUILog() . log(charArray);

~.getInstance().createSession("New Requirement™);
requirementName "My Created Requirement";
requirementId "MyReg-1";

requirementText "The system shall...";

newRequirement createRequirementElement (requirementName, requirementId,requirementText,mainModelPackage);
print("New Requirement Created")

~_getInstance().closeSession();




Managing Extensions
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Vo, Managing Extensions
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= Structured Expressions & &, CriticalLevelBoundary( Critical Element : Class [1], [
: e © itical El : Class [1 H
= Structures expressions can be stored SRR St @
Lff7 s _ I Q in Lower Bound : Real [1]=0.0 L
and reused within profiles as . O in Upper Bound : Real [1]=100.0 —
) peration
OpaqueBehaviors - © return Result : Boolean [1] bkl
= Parameters for inputs are created within e
OpaqueBehaviors and are assignable (e
within the Structured Expression &
= The Structured Expression is stored —
within the Body and Language property
of the OpaqueBehavior @ ol T T
) / | ;?Upp Bvu:é" o Operation Name: | CriticalLevelBoundary
® Simulation Somsr 8 oo
= Code for simulations is stored within the
behaviors/constraints of an Activity,

(~) Standard oK Cancel Evaluation Mode

State Machine, or Parametric Diagram.



“ ) Managing Plugins
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" Plugins
= Plugin code should be managed with an
external repository such as GitHub

= Once compiled and installed, the code
stays locked within the plugins directory
of the installation

= Plugin code is often developed in IDEs
such as IntelliJ, Eclipse, and NetBeans

= Most users will require IT support to

install plugins into CATIA Magic Q ecllp ‘e IDE
2024-06

GitHub




Vi Managing Macros
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" Macros

= Macro code can be stored within the application
OR a project.

= Macros stored to the application are added to the
Tools -> Macros menu and can be run on any

project within THAT instance of CATIA Magic. |

* Each user needing to run the macro would load it into A

their application using Tools -> Macros -> Organize
Macros

* This does NOT require elevated privileges : : e
= Macros stored to a project are maintained in a = sy i
Macro type element |
= The MacroEngine profile is loaded automatically
= All Macros in a project are automatically available
to all users of the project under Tools -> Macros

= Macros can be developed in IDEs (like Plugins) or
in advanced text editors such as Sublime or
Notepad++

asStereotype(scope,auxiliaryResourceStereotype))

ope_ getHumanType());




W Best Practices
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* When developing any extension for CATIA Magic, always consider the range of
users for the extension

= The broader the audience, the more resilient the extension needs to be to users
improperly using the code or bad data being used with it

= For very specific applications, only key users should have access to extensions

" Macros stored in projects are model elements and are thus subject to version
controlling in TWC

» Plugins should be CMed per the organization’s standard operating procedure
" For wizards and large functionality used by a team, plugins are best suited
" For automations, transformations, or reports, macros are best suited



Demo of Macros
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QUESTIONS?
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